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1 Introduction 
 

Lands Department provides the following two tools: 

i) Area Checking Tool – for generation of Lands Department General Building Plan Area Checking Report; 

and 

ii) Auto Coloring Tool – for automatic generation of area plans according to Lands Department requirements. 

This manual will illustrate procedures to use the tools. 

 

 

2 Prepare ArchiCAD File  
 

2.1 Prepare ArchiCAD Zones 

i) Start a new project by clicking “Browse” to select the provided template file “ARCHICAD Template 26.pln” 

or refer to Section 7 to transfer relevant standards to your existing projects. 
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ii) Define zones using construction method boundary. 

 

 

 

iii) Right click "zones schedule” in template, then pick “Scheme Settings” from the context menu to select the 

necessary parameters. 
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iv) Click “Add Fields…” to select zones parameters to be displayed in Zones Schedule in the template.    

 

v) Provide relevant zones parameters values via zones schedule. 
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vi) Open “File” tag, then select “Project Info…” under “Info” to input LandsD areas under land lease 

requirements. 

 

 
vii) Provide areas under land lease requirements in the value of parameters starting with “LND-Lease-Req”, 

then click “OK”. 
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2.2 Prepare ArchiCAD storey information 

i) Define a zone in each storey as a virtual zone. Required story property data will be entered to the virtual 

zone. 

 

ii) Select the virtual zone and in the “Zone Selection Settings” assign the "BUD-Level-Virtual_Zone" parameter 

with the value "True". 
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iii) Assign appropriate values to the following parameters if applicable:  

 BUD-GBP-Level-Subfloor 

 

 BUD-GBP-Level-Roof_Over_highest_UFS 

 

 BUD-GBP-Common-Premises_Location 
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2.3 Handling Hotlink/Separate Models. 

The GBP BIM Checking Tool could support submission involving multiple ArchiCAD files via two methods:  

i) Method 1 – submission of one hotlinked ArchiCAD file. With this method, all individual ArchiCAD files 

should be hotlinked to a single master ArchiCAD file. Such master ArchiCAD file should be stored in one 

independent folder without any other separate ArchiCAD files. When submission of separate ArchiCAD files 

are required, they should be stored under a separate folder. 

 

 
 

ii) Method 2 – direct submission of separate ArchiCAD file without any master files. For method 2, all separate 

ArchiCAD files should be stored under the same folder.  
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3 Area Checking Tool – Buildings Department 
 

i) Click “BD Add-Ins” tab, then click “BD Area Checking” button 

 

4 Area Checking Tool – Lands Department 
 

i) Click “LandsD Add-Ins” tab, then click “LandsD Area Checking” button.  
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5 Area Checking Excel Result 
 

i) After selecting the calculation tool, a prompt window will open for selecting the Excel result path and name 

the file. 

 

 

ii) Results will be shown in Excel. Please do not interrupt the Excel process until a complete message is 

prompted in ARCHICAD. Click “Yes” to open the Excel file. 

 

 

 



GBP BIM Checking Tool for ArchiCAD - User Manual 

LandsD Page 10  

GBP BIM Checking Tool for ArchiCAD - User Manual   Issue Date: 30 SEP 2024 
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6 Auto Coloring Tool 
   

i) Select graphic override and LandsD Colouring in template. 

 

ii) Zones will be colored automatically based on pre-defined rules. 
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7   Transfer Template Settings (for existing projects only)         

7.1 In order to transfer template settings to your existing project, you may follow the following procedures:   

i) Template Parameter Settings: Export from Property Manager and import into your project. 

ii) Project Info Parameters: Export project information from the template and import it into your active file. 

iii) Fill Types: Export and import fill types using the Attribute Manager. 

iv) Graphic Overrides: Export and import graphic override settings from the Graphic Override dialog box. 

7.2 To export parameter settings from the template file, follow procedures below:   

i) Open template file. 

ii) Open property manager (Options > Property >Manager). 

iii) Select all properties or groups for export. 

iv) Click the export button. 

 

v) Set preferred options in the dialog box: 
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7.3 To import template parameter settings to your existing project, follow procedures below:                      

i) Open active file containing the area information. 

ii) Open Property Manager (Options > Property Manager). 

iii) Click the import button. 

 

iv) In the open file dialog box, browse the XML file that contains the properties you need, then click “OK”. 

v) Set preferred options in the dialog box: 
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7.4 To export project Info parameters from the template file, follow procedures below: 

i) Open template file. 

ii) Open project info (File > Info >Project Info). 

iii) Click the export button and “OK”. 

 

7.5 To import template project Info parameters to your existing project, follow procedures below: 

i) Open your active file containing the area information. 

ii) Open project info (File > Info >Project Info). 

iii) Click the import button. 

iv) Click “OK” to save changes. 
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7.6 To export fill types in template from the template file, follow procedures below: 

i) Open your active file in ArchiCAD. 

ii) Open the attribute manager dialog box: navigate to (Options > Element Attributes > Attribute Manager). 

iii) In the attribute manager dialog box, switch to the fills tab to view all fill types. 

iv) Select all fill types. 

v) Click “By Index >>” to move selected fill types to the right list. 

vi) Click the export button to export the selected fill types. 

 

  

7.7 To import fill types in template to your existing project, follow procedures below: 

i) Open your active file containing the area information. 

ii) Open the attribute manager dialog box: (navigate to Options > Element Attributes > Attribute Manager). 

iii) Click the import button for the selected fill types. 

iv) In the attribute manager dialog box, switch to the fills tab to view all imported fill types. 

v) Select all Imported fill types. 

vi) Click “<< By Index” to move selected fill types to the left list. 

vii) Click “OK” to save changes. 

 



GBP BIM Checking Tool for ArchiCAD - User Manual 

LandsD Page 16  

GBP BIM Checking Tool for ArchiCAD - User Manual   Issue Date: 30 SEP 2024 

 

 

 

7.8 To export graphic overrides settings from the template file, follow procedures below: 

i) Open template file. 

ii) Open graphic override dialogue box (Document > Graphic Overrides > Graphic Override Combinations). 

iii) Select one or more graphic override combinations. 

iv) Use the buttons at the bottom of the combinations dialog to export selected combinations in XML format. 
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7.9 To import template graphic overrides setting to your existing project, follow procedure belows: 

i) Open your active file containing the area information. 

ii) Open graphic override dialogue box (Document> Graphic Overrides > Graphic Override>Combinations). 

iii) Select one or more graphic override combinations. 

iv) Use the buttons at the bottom of the combinations. 

v) Import selected combinations in XML format. 
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A Appendix – List of Area Information and Parameter Naming 

Calculations Area Information Related Parameter Name 1 Related Parameter Name 2 Remarks 

Non-Domestic SC 
calculations 

Site Coverage Definition BUD-GBP-SC-Site_Coverage_Definition 
  

 
Curtain walling system LND-GBP-SC-Curtain_Wall 

 
required only when accountable 
under lease  

Ad hoc items under lease LND-GBP-SC-Non_Domestic_Ad_Hoc_Items_Under_Lease 
  

Domestic SC calculations Site Coverage Definition BUD-GBP-SC-Site_Coverage_Definition 
  

 
Curtain walling system LND-GBP-SC-Curtain_Wall 

 
required only when accountable 
under lease  

Caretaker's/watchman office LND-GBP-SC-Caretaker_Office 
  

 
Caretaker's/watchman quarters LND-GBP-SC-Caretaker_Quarter 

  

 
Owners' corporation / owners' committee 
office 

LND-GBP-SC-Owner_Office 
  

 
Ad hoc items under lease LND-GBP-SC-Domestic_Ad_Hoc_Items_Under_Lease 

  

Non-Domestic GFA 
calculations 

GFA Definition BUD-GBP-GFA-GFA_Definition BUD-GBP-GFA-
Function_of_Area 

 

 
Car parking / Loading and unloading / Run-
in/out or Driveway Zone ID  

BUD-GBP-GFA-Carpark_Zone 
  

 
Apportionment Factor  BUD-GBP-GFA-Bonus_GFA_Apportionment_Factor 

  

 
GFA Concession Definition BUD-GBP-GFA-GFA_Concession_Definition BUD-GBP-GFA-GFA_Definition 

 

 
GFA Concession 2 Definition BUD-GBP-GFA-GFA_Concession_2_Definition BUD-GBP-GFA-GFA_Definition 

 

 
Curtain walling system LND-GBP-GFA-Curtain_Wall BUD-GBP-GFA-GFA_Definition required only when accountable 

under lease  
Covered Walkway required under lease LND-GBP-GFA-Covered_Walkway_Required_Under_Lease BUD-GBP-GFA-GFA_Definition 

 

 
Residential Care Homes for the Elderly LND-GBP-GFA-Home_Elderly BUD-GBP-GFA-GFA_Definition 

 

 
Government Accommodation LND-GBP-GFA-Government_Accommodation BUD-GBP-GFA-GFA_Definition 

 

 
Public transport terminus LND-GBP-GFA-Public_Transport_Terminus BUD-GBP-GFA-GFA_Definition 

 

 
Public Vehicle Park LND-GBP-GFA-Public_Vehicle_Park BUD-GBP-GFA-GFA_Definition 

 

 
Ad hoc items under lease LND-GBP-GFA-

Non_Domestic_Ad_Hoc_Items_Under_Lease 
BUD-GBP-GFA-GFA_Definition 

 

Domestic GFA 
calculations 

GFA Definition BUD-GBP-GFA-GFA_Definition 
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Car parking / Loading and unloading / Run-
in/out or Driveway Zone ID  

BUD-GBP-GFA-Carpark_Zone 
  

 
Apportionment Factor  BUD-GBP-GFA-Bonus_GFA_Apportionment_Factor 

  

 
GFA Concession Definition BUD-GBP-GFA-GFA_Concession_Definition BUD-GBP-GFA-GFA_Definition 

 

 
GFA Concession 2 Definition BUD-GBP-GFA-GFA_Concession_2_Definition BUD-GBP-GFA-GFA_Definition 

 

 
Curtain walling system LND-GBP-GFA-Curtain_Wall BUD-GBP-GFA-GFA_Definition required only when accountable 

under lease  
Covered Walkway required under lease LND-GBP-GFA-Covered_Walkway_Required_Under_Lease BUD-GBP-GFA-GFA_Definition 

 

 
Residential Care Homes for the Elderly LND-GBP-GFA-Home_Elderly BUD-GBP-GFA-GFA_Definition 

 

 
Public Vehicle Park LND-GBP-GFA-Public_Vehicle_Park BUD-GBP-GFA-GFA_Definition 

 

 
Ad hoc items under lease LND-GBP-GFA-Domestic_Ad_Hoc_Items_Under_Lease BUD-GBP-GFA-GFA_Definition 

 

NOFA calculations NOFA Definition LND-GBP-NOFA-Classification LND-GBP-Common-Quantity 
 

 
Ad hoc items under lease LND-GBP-NOFA-Ad_Hoc_Items_Under_Lease LND-GBP-Common-Quantity 

 

Greenery calculations Greenery Definition BUD-GBP-Greenery-Greenery_Definition LND-GBP-Common-Quantity 
 

 
Primary Zone BUD-GBP-Greenery-Primary_Zone LND-GBP-Common-Quantity 

 

 
Area for green roof calculations LND-GBP-Greenery-Green_Roof LND-GBP-Common-Quantity 

 

 
Ad hoc items under lease LND-GBP-Greenery-Ad_Hoc_Items_Under_Lease LND-GBP-Common-Quantity 

 

Open Space calculations Open Space Definition LND-GBP-OpenSpace-Classification LND-GBP-Common-Quantity 
 

 
Ad hoc items under lease LND-GBP-OpenSpace-Ad_Hoc_Items_Under_Lease LND-GBP-Common-Quantity 

 

Site Information Lot Area under lease LND-GBP-Common-Lot-Area-Under-Lease 
  

Common Properties Area ID BUD-GBP-Common-Area_ID 
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B Appendix – Automatic Colouring Logic 

Color Parameter Name Parameter Value 

ORANGE BUD-GBP-GFA-GFA_Definition 
Domestic area 

or 
Domestic area to be disregarded from BD GFA calculations only 

DEEP BLUE 
HATCHED WHITE 

BUD-GBP-GFA 
GFA_Concession_Definition 

05 Balcony  
or 

12 Utility platform 

DEEP BLUE CROSS 
HATCHED WHITE 

BUD-GBP-GFA-GFA_Definition 
 

Domestic area to be disregarded from GFA calculations 
or 

Domestic area to be disregarded from BD GFA calculations only 
or 

Non-Domestic area to be disregarded from GFA calculations 
or 

Non-Domestic area to be disregarded from BD GFA calculations only 

 And 

BUD-GBP-GFA 
GFA_Concession_Definition 

14 Counters, Kiosks, Offices, Stores, Guard Rooms, and Lavatories for 
Watchmen and Management Staff (serving domestic) 

or 
14 Counters, Kiosks, Offices, Stores, Guard Rooms, and Lavatories for 

Watchmen and Management Staff (serving non-domestic) 

DEEP BLUE CROSS 
HATCHED BLACK 

BUD-GBP-GFA 
GFA_Concession_Definition 

14 Caretakers' Quarters 

DEEP BLUE 
STIPPLED WHITE 

BUD-GBP-GFA 
GFA_Concession_Definition 

14 Owners' Corporation Office 

DEEP BLUE 
STIPPLED BLACK 

BUD-GBP-GFA 
GFA_Concession_Definition 

15 Residential recreational facilities including void, plant room, swimming pool 
filtration plant room, covered walkway, etc. serving solely the recreational 

facilities 

RED CROSS 
HATCHED WHITE 

 
BUD-GBP-GFA-GFA_Definition 

 

Non-domestic area 
or 

Non-domestic area to be disregarded from BD GFA calculations only 

 And 
 

BUD-GBP-GFA-Function_of_Area Office 

RED CROSS 
HATCHED BLACK 

 
BUD-GBP-GFA-GFA_Definition 

 

Non-domestic area 
or 

Non-domestic area to be disregarded from BD GFA calculations only 

 And 
 

BUD-GBP-GFA-Function_of_Area Shopping Arcade 

RED STIPPLED 
WHITE 

 
BUD-GBP-GFA-GFA_Definition 

 
 

Non-domestic area 
or 

Non-domestic area to be disregarded from BD GFA calculations only 

 And 

BUD-GBP-GFA-Function_of_Area 

Hotel FOH or Hotel BOH (GFA accountable or Hotel Accountable GFA 
(Domestic accommodation) 

 or  
Hotel Accountable GFA (Non-Domestic accommodation) 

 
 

Red 
 
 

BUD-GBP-GFA-GFA_Definition 
Non-domestic area 

or 
"Non-domestic area to be disregarded from BD GFA calculations only 

DEEP BLUE 

BUD-GBP-GFA 
GFA_Concession_Definition 

Concessions With Cap 

 And 

BUD-GBP-GFA-GFA_Definition 
Domestic area to be disregarded from GFA calculations  

or 
Domestic area to be disregarded from LandsD GFA calculations only 

LIGHT BLUE 
BUD-GBP-GFA 

GFA_Concession_Definition 
Concessions With Cap 

 And 
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BUD-GBP-GFA-GFA_Definition 
Non-domestic area to be disregarded from GFA calculations  

or  
Non-domestic area to be disregarded from LandsD GFA calculations only 

PURPLE 
BUD-GBP-GFA 

GFA_Concession_Definition 
Not contains Concessions With Cap 

WOOD 
BUD-GBP-GFA 

GFA_Concession_Definition 
01 carpark, loading/unloading areas and driveway that are 100% disregarded 

WOOD HATCHED 
BLACK 

BUD-GBP-GFA 
GFA_Concession_Definition 

01 carpark, loading/unloading areas and driveway that are 50% disregarded 

WOOD HATCHED 
WHITE 

BUD-GBP-GFA 
GFA_Concession_Definition 

01 driveway/carpark ancillary areas that are disregarded on pro rata 

 

The table above provides a colour schema based on the value of certain parameters and below explains the conditions 

of “Or”, “And” and “Not Contains”:: 

 Or: This means that the colour applies if any of the listed conditions are met.  

 And: This means that the colour applies only if all the listed conditions are met simultaneously.  

 Not Contains: This means that the colour applies when a certain condition is not met. 

“ConcessionsWithCap” values  

1. "02.3 A/C plant room" 

2. "02.3 AHU room" 

3. "02.3 other Non-mandatory/non-essential plant rooms disregarded under B(P)R 23(3)(b)" 

4. "11 Non-structural prefabricated external wall" 

5. "14 Owners' Corporation Office" 

6. "15 Residential recreational facilities including void, plant room, swimming pool filtration plant room, covered 

walkway, etc. serving solely the recreational facilities" 

7. "17 Horizontal screen/covered walkway subject to 10% overall cap" 

8. "18 Larger lift shaft - Office" 

9. "18 Larger lift shaft - Hotel" 

10. "19 Chimney shaft" 

11. "20 Non-mandatory/non-essential plant room exempted under B(P)R 23(3)(a) such as boiler room, SMATV, 

filtration plant room" 

12. "22 Pipe duct, air duct for non-mandatory or non-essential plant room" 

13. "25 Void over main common entrance (prestige entrance) in non-domestic development" 

14. "29 Other projection not covered in paragraph 3(b) and (c) of PNAP APP-19" 

15. "05 Balcony" 

16. "05 Covered area underneath Balcony" 

17. "06 Wider common corridor and lift lobby for residential buildings" 

18. "12 Utility platform" 

19. "12 Covered area underneath Utility Platform" 

20. "14 Counters, Kiosks, Offices, Stores, Guard Rooms, and Lavatories for Watchmen and Management Staff 

(serving domestic)" 

21. "14 Caretakers' Quarters" 

22. "18 Larger lift shaft - Domestic" 

23. "26 Void in duplex domestic flat" 

24. "26 Void in house" 


